رفتن به مطلب

پست های پیشنهاد شده

سلام چند وقتی است برخی لینک های سایتم با اینکه وجود دارند 404 میشوند

وقتی توی سایت سرچ میکنم پست را میاره اما وقتی بازش میکنم 404 میشه

باید برم از نوشته ها لینکش را عوض کنم تا درست بشه

شکل لینک هام:

/%category%/%postname%

 

هاست عوض کنم ، لینک ها را هم عوض کردم اما امروز مجدد اولن پست 404 توی سایتم مشاهده کردم

به اشتراک گذاری این ارسال


لینک به ارسال
در 3 ساعت قبل، kasra277 گفته است :

 

 

سلام فایل httass. اسم کاملش یادم نیست

داخل روت هاست موجوده بازش کن کدای داخلش و پاک کن سیو کن 

بعد برو پیوند یکتا مجدد اون تنظیم دلخاه کن

مرسی از جوابتون اما این کار را قبلا کرده بودم جوای نگرفتم ازش

به اشتراک گذاری این ارسال


لینک به ارسال

به عنوان مثال لینک زیر را باز کنید

http://idrama1.xyz/tag/iu

و اون پستی که عکس تکی داره و مربوط به دسته بازیگران است را باز کنید 404 میشه

منظورم این لینک است

http://idrama1.xyz/actor/iu

به اشتراک گذاری این ارسال


لینک به ارسال
در 17 ساعت قبل، kasra277 گفته است :

چرا نمیشه ؟!!

سایت کلی بازدید داره و تازه تاسیس نیست + اینکه بعد از چند مدت توسط گوگل متوجه میشم که برخی از لینک ها 404 شدن

 

اما در کل وقتی پوسته عوض کنم ، باز هم 404 نشون میده لیک مورد نظر

ویرایش شده توسط neda411

به اشتراک گذاری این ارسال


لینک به ارسال

سلام دوست عزیز ، مشکل از کد های قالبتون هست، تم مورد استفاده اتون رو بررسی کنید ، استایل دسته هنرمندان مشکل داره 

http://idrama1.xyz/actor

http://idrama1.xyz/music

http://idrama1.xyz/series

میبینید در بایگانی لینک هنرمندانتون هم مشکل وجود داره ولی در بخش موزیک و  سریالتون این مشکل نیست و این مشکلی 404 شدن هم اگر دقت کنید فقط در دسته هنرمندان اتفاق افتاده T توی کنسول هم خطا دارید که در صفحات دیگه وجود نداره 

eror.thumb.png.824ff4f017b476e9a4e7365665b56055.png

ویرایش شده توسط soma

به اشتراک گذاری این ارسال


لینک به ارسال

سلام

دوستان من هم همین مشکل رو دارم 

فقط url رو که تغییر میدم درست میشه

سایت تازه تاسیس نیست و صفحه مورد نظر لینک دو گوگل هست !

 

لطفا دلیل و راه حلی که می دونین رو بهم بگید

ممنون

به اشتراک گذاری این ارسال


لینک به ارسال

سلام

@neda411 و @Mrbugx

این راه رو تست کنید :

وارد کنترل پنل هاست خودتون شید، فایل .htaccess رو حذف کنید.
بعد از اون وارد پیشخوان سایت وردپرسی خودتون شید، به بخش "تنظیمات>پیوند های یکتا" برید
نوع پیوند یکتا رو روی حالت دلخواه خودتون قرار بدید و در نهایت روی دکمه "ذخیره تغییرات" کلیک کنید.

 

 

ویرایش شده توسط Ehsan Np

به اشتراک گذاری این ارسال


لینک به ارسال
در 7 دقیقه قبل، Ehsan Np گفته است :

سلام

@neda411 و @Mrbugx

این راه رو تست کنید :

وارد کنترل پنل هاست خودتون شید، فایل .htaccess رو حذف کنید.
بعد از اون وارد پیشخوان سایت وردپرسی خودتون شید، به بخش "تنظیمات>پیوند های یکتا" برید
نوع پیوند یکتا رو روی حالت دلخواه خودتون قرار بدید و در نهایت روی دکمه "ذخیره تغییرات" کلیک کنید.

 

 

 سلام

متاسفانه درست نشد .

هر راه و کاری که به ذهنم میرسید رو انجام دادم 

به اشتراک گذاری این ارسال


لینک به ارسال

@Mrbugx

محتوای فایل .htaccess خودتون رو به محتوای زیر تغییر بدید :

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

بعد از قرار دادن کد ها؛ فایل رو ذخیره و دسترسی فایل رو به 660 تغییر بدید.

به اشتراک گذاری این ارسال


لینک به ارسال
در 1 دقیقه قبل، Ehsan Np گفته است :

@Mrbugx

محتوای فایل .htaccess خودتون رو به محتوای زیر تغییر بدید :


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

بعد از قرار دادن کد ها؛ فایل رو ذخیره و دسترسی فایل رو به 660 تغییر بدید.

باز فرقی نکرد و کلا نیاورد

404

Not Found

The resource requested could not be found on this server!

به اشتراک گذاری این ارسال


لینک به ارسال
در 2 دقیقه قبل، Ehsan Np گفته است :

@Mrbugx اگر ممکنه لینک سایتتون رو بدید تا یه نگاه بندازم

بفرمایید

https://sabaprofile.com/پروفیل-سنگین/

ویرایش شده توسط Mrbugx

به اشتراک گذاری این ارسال


لینک به ارسال

@Mrbugx کد های زیر رو جایگزین فایل htaccess کنید.

# BEGIN WordPress
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

Header set X-Pingback "http://www.example.com/xmlrpc.php"
Header set Content-Language "fa-IR"

Header always set X-Content-Type-Options "nosniff"
Header always set X-XSS-Protection "1; mode=block"
Header always set Referrer-Policy "strict-origin-when-cross-origin"


# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]
# END WordPress

#uploaded files
RewriteRule ^(.*/)?files/$ index.php [L]
RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]

# add a trailing slash to /wp-admin
RewriteCond %{REQUEST_URI} ^.*/wp-admin$
RewriteRule ^(.+)$ $1/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]
# END WordPress

 

به اشتراک گذاری این ارسال


لینک به ارسال
در 1 دقیقه قبل، Ehsan Np گفته است :

@Mrbugx کد های زیر رو جایگزین فایل htaccess کنید.


# BEGIN WordPress
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

Header set X-Pingback "http://www.example.com/xmlrpc.php"
Header set Content-Language "fa-IR"

Header always set X-Content-Type-Options "nosniff"
Header always set X-XSS-Protection "1; mode=block"
Header always set Referrer-Policy "strict-origin-when-cross-origin"


# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]
# END WordPress

#uploaded files
RewriteRule ^(.*/)?files/$ index.php [L]
RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]

# add a trailing slash to /wp-admin
RewriteCond %{REQUEST_URI} ^.*/wp-admin$
RewriteRule ^(.+)$ $1/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]
# END WordPress

 

بی فایدس 

جواب نداد

به اشتراک گذاری این ارسال


لینک به ارسال
در هم اکنون، Mrbugx گفته است :

بی فایدس 

جواب نداد

یک بار نوع پیوند یکتا رو به حالت پیش فرض (site/?p=ID) تغییر بدید و ذخیره کنید.

بعد محتوای خودتون رو چک کنید و بعدش به نوع لینک دلخواه خودتون تغییر بدید.

یه مورد دیگه هم خدمتتون عرض کنم که افزونه WP-Optimize رو نصب کنید و دیتابیس خودتون رو بهینه سازی کنید و بعد از اون نتیجه رو اعلام کنید

به اشتراک گذاری این ارسال


لینک به ارسال
در 11 دقیقه قبل، Ehsan Np گفته است :

یک بار نوع پیوند یکتا رو به حالت پیش فرض (site/?p=ID) تغییر بدید و ذخیره کنید.

بعد محتوای خودتون رو چک کنید و بعدش به نوع لینک دلخواه خودتون تغییر بدید.

یه مورد دیگه هم خدمتتون عرض کنم که افزونه WP-Optimize رو نصب کنید و دیتابیس خودتون رو بهینه سازی کنید و بعد از اون نتیجه رو اعلام کنید

روش اول که جواب نداد اما روش دوم رو بزارید تست کنم

به اشتراک گذاری این ارسال


لینک به ارسال
در 15 دقیقه قبل، Ehsan Np گفته است :

یک بار نوع پیوند یکتا رو به حالت پیش فرض (site/?p=ID) تغییر بدید و ذخیره کنید.

بعد محتوای خودتون رو چک کنید و بعدش به نوع لینک دلخواه خودتون تغییر بدید.

یه مورد دیگه هم خدمتتون عرض کنم که افزونه WP-Optimize رو نصب کنید و دیتابیس خودتون رو بهینه سازی کنید و بعد از اون نتیجه رو اعلام کنید

روش دوم هم بی فایده بود متاسفانه

به اشتراک گذاری این ارسال


لینک به ارسال

@Mrbugx

در حال حاضر دیگه راه حلی بنظرم نمیرسه مگر اینکه بتونم به صورت آنلاین سایتتون رو بررسی کنم.

اگر امکانش فراهم شد و وبسایتتون رو آنلاین کردید و احیاناً این مشکل پابرجا بود، اطلاع بدید تا بررسی کنم و راه حل رو خدمتتون اعلام کنم.

به اشتراک گذاری این ارسال


لینک به ارسال
در 6 دقیقه قبل، Ehsan Np گفته است :

@Mrbugx

در حال حاضر دیگه راه حلی بنظرم نمیرسه مگر اینکه بتونم به صورت آنلاین سایتتون رو بررسی کنم.

اگر امکانش فراهم شد و وبسایتتون رو آنلاین کردید و احیاناً این مشکل پابرجا بود، اطلاع بدید تا بررسی کنم و راه حل رو خدمتتون اعلام کنم.

بالاتر لینک رو گذاشتم

به اشتراک گذاری این ارسال


لینک به ارسال

@Ehsan Np 

 

 

مشکل رو یافتم

وارد دیتابیس از PHPMYADMIN شدم، و table مربوط به پست ها رو چک کردم و یک صفحه تکراری بود که داپلیکیت حساب میکرد و تاریخ ایجادش مربوط به یک سال پیش بود با وضعیت نامشخص حذف کردم اوکی شد

به اشتراک گذاری این ارسال


لینک به ارسال

به گفتگو بپیوندید

هم اکنون می توانید مطلب خود را ارسال نمایید و بعداً ثبت نام کنید. اگر حساب کاربری دارید، برای ارسال با حساب کاربری خود اکنون وارد شوید .

مهمان
ارسال پاسخ به این موضوع ...

×   شما در حال چسباندن محتوایی با قالب بندی هستید.   حذف قالب بندی

  تنها استفاده از 75 اموجی مجاز می باشد.

×   لینک شما به صورت اتوماتیک جای گذاری شد.   نمایش به صورت لینک

×   محتوای قبلی شما بازگردانی شد.   پاک کردن محتوای ویرایشگر

×   شما مستقیما نمی توانید تصویر خود را قرار دهید. یا آن را اینجا بارگذاری کنید یا از یک URL قرار دهید.


×
×
  • اضافه کردن...