fun_9990

چگونگی رفع مشکل ریدایرکت از ساب فولدر به فولدر اصلی

12 پست در این موضوع قرار دارد

بنده دو تا ورد پرس نصب کردم 

یکی در پوشه روت سایت

و یکی هم در یک زیر پوشه در همین سایت به عبارتی

/*****/public_html

و

/******/public_html/second

الان وقتی داخل ورد پرس پایینی پستی ارسال میشه و من می خوام روی اون پست کلیک کنم و محتویاتش رو ببینم ریدایرت میشه به سایت اصلی و خطای 404 میده

می خوام ببینم می تونم مشکل رو از htaccess حل کنم یا نه ؟  

داخلش این خط رو اضافه کردم اما مشکلم حل نشد 

RewriteRule ^second/ - [L,NC]

 

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

اگر سایتتون رو در ساب فورلدر کپی کردین و به دیتابیس وصل کردین و فقط از طریق جدول  wp-option مسیر رو اصلاح کردید  حتما یک بار پیوندهای یکتا رو روی حالت  ساده بگذارید ، ذخیره کنید و مجددا بعدش پیوندهای یکتا رو به حالت دلخواهتون تغییر بدید ، احتمالا با همین مشکلتون حل میشه

مسیر پیوندهای یکتا  در پیشخوان هم در

تنظیمات > پیوندهای یکتا 

 

 

ویرایش شده در توسط soma
0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

در 12 دقیقه قبل، soma گفته است :

اگر سایتتون رو در ساب فورلدر کپی کردین و به دیتابیس وصل کردین و فقط از طریق جدول  wp-option مسیر رو اصلاح کردید  حتما یک بار پیوندهای یکتا رو روی حالت  ساده بگذارید ، ذخیره کنید و مجددا بعدش پیوندهای یکتا رو به حالت دلخواهتون تغییر بدید ، احتمالا با همین مشکلتون حل میشه

مسیر پیوندهای یکتا  در پیشخوان هم در

تنظیمات > پیوندهای یکتا 

 

 
 

من خیلی ساده سوالم رو توضیح دادم . چرا شما پیچیدش کردین. دو تا وردپرس نصب کردم تو دو تا فولدر با دو تا دیتابیس مجزا

ویرایش شده در توسط fun_9990
0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

در 9 دقیقه قبل، fun_9990 گفته است :

من خیلی ساده سوالم رو توضیح دادم . چرا شما پیچیدش کردین. دو تا وردپرس نصب کردم تو دو تا فولدر با دو تا دیتابیس مجزا

چیز پیچیده ای نگفتم دوست عزیز، من یک راه حل ساده برای مسئله ای که در خیلی موارد پیش میاد گفتم  ،  ابتدا یک بار تست کنید و پیوند های یکتا رو به ساده تغییر بدید و سایت رو رفرش کنید ، چک کنید ببینید آیا باز هم صفحاتتون رو باز میکنید 404 میده یا پستتون باز میشه؟ اگر ارور 404 نداد و پست باز شد ، مجددا پیوندهای یکتا رو به حالتی که مایلید تغییر بدید و ذخیره کنید و سایت رو رفرش کنید ببیند

احتمال 99 درصد میگم مشکلتون حل میشه 

 

ویرایش شده در توسط soma
0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

در 11 دقیقه قبل، soma گفته است :

چیز پیچیده ای نگفتم دوست عزیز، من یک راه حل ساده برای مسئله ای که در خیلی موارد پیش میاد گفتم  ،  ابتدا یک بار تست کنید و پیوند های یکتا رو به ساده تغییر بدید و سایت رو رفرش کنید ، چک کنید ببینید آیا باز هم صفحاتتون رو باز میکنید 404 میده یا پستتون باز میشه؟ اگر ارور 404 نداد و پست باز شد ، مجددا پیوندهای یکتا رو به حالتی که مایلید تغییر بدید و ذخیره کنید و سایت رو رفرش کنید ببیند

احتمال 99 درصد میگم مشکلتون حل میشه 

 

ممنون

بعد اینکه تغییرات رو اعمال می کنم اما باز هم خطای 404 برمیگردونه 

ویرایش شده در توسط fun_9990
0

به اشتراک گذاری این پست


لینک به پست
در هم اکنون، fun_9990 گفته است :

ممنون

بعد اینکه تغییرات رو اعمال می کنم به صورت خود به خود به تنظیمات گذشته برمیگرده

منظورتون رو متوجه نشدم ؟ 

 

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

در 25 دقیقه قبل، fun_9990 گفته است :

ممنون

بعد اینکه تغییرات رو اعمال می کنم اما باز هم خطای 404 برمیگردونه 

 

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /second/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /second/index.php [L]
</IfModule>

# END WordPress

اول از فایل htaccess  وردپرسی که در ساب فولدر هست دانلود کنید جهت اطمینان نگه دارید ، بعد کدهای بالا رو در فایل htaccess  وردپرسی که توی ساب فولدر هست کپی کنید

دقیقا فکر کنم مشکل خط زیر هست که گذاشتید 

RewriteRule ^second/ - [L,NC]

باید این خط به این صورت باشه 

RewriteRule ^index\.php$ - [L]

 

ویرایش شده در توسط soma
0

به اشتراک گذاری این پست


لینک به پست
در 3 دقیقه قبل، soma گفته است :

 


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /second/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /second/index.php [L]
</IfModule>

# END WordPress

اول از فایل htaccess  وردپرسی که در ساب فولدر هست دانلود کنید جهت اطمینان نگه دارید ، بعد کدهای بالا رو در فایل htaccess  وردپرسی که توی ساب فولدر هست کپی کنید

 

بازم نشد

0

به اشتراک گذاری این پست


لینک به پست

اگر مایلید رمز پنل ورود به ادمین وردپرستون رو خصوصی بفرستید و همینطور هاست یه چک بکنم 

 

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

در 2 دقیقه قبل، soma گفته است :

اگر مایلید رمز پنل ورود به ادمین وردپرستون رو خصوصی بفرستید و همینطور هاست یه چک بکنم 

 

نه ممنون خودم یه راحی برای حل کردنش پیدا می کنم . سپاس از وقتی که گذاشتین "گُل"

ویرایش شده در توسط fun_9990
0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

خواهش میکنم ، 

فقط یک سوال از افزونه  خاصی استفاده میکنید شاید تاثیر اون باشه ، یکی یکی افزونه هاتون رو غیر فعال کنید ببینید شاید مشکل از افزونه ها باشه 

دیگه هرچیزی به ذهنم رسید رو گفتم بهتون 

امیدوارم تونسته باشم کمک کنم

ویرایش شده در توسط soma
0

به اشتراک گذاری این پست


لینک به پست
در 3 دقیقه قبل، soma گفته است :

خواهش میکنم ، 

فقط یک سوال از افزونه  خاصی استفاده میکنید شاید تاثیر اون باشه ، یکی یکی افزونه هاتون رو غیر فعال کنید ببینید شاید مشکل از افزونه ها باشه 

دیگه هرچیزی به ذهنم رسید رو گفتم بهتون 

امیدوارم تونسته باشم کمک کنم

بله می تونه مشکل از این باشه بررسی می کنم سپاسگذارم

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری