mk-73

مشکل دراجرای کوئری

4 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

دوستان سلام

من یک کوئری زدم برای داینامیک کردن اسلایدر سایت خود اما وقتی من این کوئری را قرار میدم پست ها ومطالب وتصاویر شاخص دیگه لینک نمیشه به ادامه مطلب یعنی اینجوری لینکشون غیر فعال میشه اما وقتی این کد را برمیدارم درست میشه،مشکلن از کجا میتونه باشه/بعد این اسلایدر من تصاویرش دارای کپشن هستن اما کپشن این تصاویر به این شکل است ک به هرعکس باید درحالت استاتیک بود یک titleتعریف میکردیم وتایتل خود را قرار میدادیم اما دراینجا برای داینامیک کردنش نمیدونم باید چه کدی را بزنم./چون بخش کپشن مستقل از عکس نیست.

<!--begin media-gallery-img-->
	<?php $ro_slider_query= new WP_Query(array(
	'post_type' => 'post',
	'post_status' => 'publish',
	'category_name'	=>	'news-slider',
	'order' => 'DESC',
	'orderby' => 'ID',
	'posts_per_page' =>'8',
));
if($ro_slider_query->have_posts()) : ?>
<ul class="bxslider">

	<?php
			$is_first_item = true;
			while($ro_slider_query->have_posts()) : $ro_slider_query->the_post();
				$thumb_id = get_post_thumbnail_id();
				$thumb_url_array = wp_get_attachment_image_src($thumb_id, 'full', true);
				$thumb_url = $thumb_url_array[0];
				$item_class = 'item';
				if( $is_first_item ){ 
					$item_class .= ' active';
					$is_first_item = false;
				} ?>

		<li><a href="<?php the_permalink(); ?>"><img src="<?php echo $thumb_url; ?>"></a></li>
	<?php endwhile; ?>	
</ul>
<?php endif; wp_reset_query(); ?>

<script type="text/javascript">
$(document).ready(function(){
  $('.bxslider').bxSlider({
    slideWidth: 200,
    minSlides: 2,
    maxSlides:7,
    slideMargin: 10,
 auto: true,
 slideWidth: 190,
captions: true
  });
});
</script>

<!--end  media-gallry-img-->

خوده اسلایدر درست کار میکنه ومشکلی نداره.

ویرایش شده در توسط mk-73
0

به اشتراک گذاری این پست


لینک به پست

درست شد دوستان ممنون فقط اگر کسی بتونه بگه چطوری تایتله عکس همو نشون بدم خیلی ممنون میشم ببینید در حالت استاتیک اینجوری کد اسلایدهام بود

<li><a href="#"><img src="<?php bloginfo('template_url');?>/img/cS-4.jpg" title="اینجا تایتله عکس هام قرار داره" /></a></li>

 

0

به اشتراک گذاری این پست


لینک به پست

دوستان خواهشن اگه کسی میدونه مشکل این کجاست راهنماییم کنه من الان از این کد استفاده کردم برای داینامیک کردن اسلایدرم خوب در لوکال خوبه و درست کارمیکنه اما در زمانی ک روی سایت خود قرار دادم تایتله عکس هامو نشون نمیده و درصورتی ک insecpetمیگیرم تایتل را درون یک تگ spanاز پایگاه داده خونده شد است اما نمایش داده نمیشه

<!--begin media-gallery-img-->
<div class="col-md-12 hidden-xs">
<?php query_posts('showposts=6&offset=0&category_name=چندرسانه ای'); if(have_posts()){ ?>
<ul class="bxslider">
	<?php while (have_posts()) : the_post(); ?>
<li><a href="<?php the_permalink(); ?>"><?php the_post_thumbnail('large',array('title' =>  get_the_title())); ?></a></li>
	<?php endwhile; ?>	
</ul>
<?php } wp_reset_query(); ?>
<script type="text/javascript">
$(document).ready(function(){
  $('.bxslider').bxSlider({
 slideWidth: 200,
    minSlides: 2,
    maxSlides:7,
    slideMargin: 10,
 auto: true,
captions: true
  });
});
</script>
</div>
<!--end  media-gallry-img-->

اینم ادرس سایت من در انتهای سایت این اسلایدر قرار داده شده است http://koshkoonline.ir/

0

به اشتراک گذاری این پست


لینک به پست

ممنون دوستان مشکلم حل شد/;)

0

به اشتراک گذاری این پست


لینک به پست