رفتن به مطلب
chemist

ارور بعد از بروزرسانی وردپرس

پست های پیشنهاد شده

با سلام و عرض خسته نباشید؛

بنده افزونه ای برای خبر نامه نصب کردم، (افزونه را از پوشه پلاگین های یک سایت دیگر زیپ، دانلود و در سایتم نصب کردم) هیچ اروری موجود نبود. بعد که وردپرس رو بروزرسانی کردم (نسخه 4.6) با این ارور مواجه شدم:

Warning: ini_get_all() has been disabled for security reasons in /home/chemist/public_html/wp-includes/load.php on line 1020


Headers already sent in /home/shimisti/public_html/wp-includes/load.php on line 1020
This is not a good sign, it may just be a poorly written plugin but Headers should not have been sent at this point.
Check the code in the above mentioned file to fix this problem

با غیر فعالسازی افزونه نصب شده و ارتقا نسخه پی اچ پی هاست به 5.6 نیز ارور برطرف نشد. ممنون میشم اگه راهنمایی بفرمائید.

 

ویرایش شده توسط chemist

به اشتراک گذاری این ارسال


لینک به ارسال

چیزی که هست شما کدتون یه مشکل و مورد امنیتی داره که در خط 1020 از سورس فایل load.php هستش

ببینید و بررسی کنید که مشکل چیه یا بزارید اینجا در اسرع وقت دیده بشه

به اشتراک گذاری این ارسال


لینک به ارسال

این مشکل که با بروزرسانی به نسخه 4.6 ایجاد می شود در اکثر موارد با ارتقا نسخه php به 5.6 مرتفع می شود ولی فکر کنم به دلیل عدم سازگاری قالب با php نسخه 5.6 باشه که این مشکل حل نشد.

در فایل .htaccess  با تغییر

AddType Application/x-httpd-php53 php

به

AddType Application/x-httpd-php56 php

سایت به کل از دسترس خارج می شود.

ممنون میشم اگر دوستان روش سازگارسازی قالب با نسخه جدید پی اچ پی را بفرمایند.

به اشتراک گذاری این ارسال


لینک به ارسال
در 52 دقیقه قبل، chemist گفته است :

این مشکل که با بروزرسانی به نسخه 4.6 ایجاد می شود در اکثر موارد با ارتقا نسخه php به 5.6 مرتفع می شود ولی فکر کنم به دلیل عدم سازگاری قالب با php نسخه 5.6 باشه که این مشکل حل نشد.

در فایل .htaccess  با تغییر

AddType Application/x-httpd-php53 php

به

AddType Application/x-httpd-php56 php

سایت به کل از دسترس خارج می شود.

ممنون میشم اگر دوستان روش سازگارسازی قالب با نسخه جدید پی اچ پی را بفرمایند.

باید به پشتیبانی هاستتون پیام بدین و ازشون بخواهید php شما را ارتقا بدهند نه اینکه توی htaccess تغییر بدهید

به اشتراک گذاری این ارسال


لینک به ارسال

ممنون از شما؛ بله بنده هم دقیقاً همین کار رو انجام دادم. از طریق سی پنل نسخه پی اچ پی رو ارتقا دادم و با پشتیبانی هاست هم در میان گذاشتم، نظر پشتیبانی هاست هم همین بود.

به اشتراک گذاری این ارسال


لینک به ارسال
در ۱ ساعت قبل، chemist گفته است :

ممنون از شما؛ بله بنده هم دقیقاً همین کار رو انجام دادم. از طریق سی پنل نسخه پی اچ پی رو ارتقا دادم و با پشتیبانی هاست هم در میان گذاشتم، نظر پشتیبانی هاست هم همین بود.

این مشکل نه تنها برای شما بلکه برای خیلی ها اتفاق افتاده و باید منتظر نسخه جدید وردپرس باشیم

به اشتراک گذاری این ارسال


لینک به ارسال

سلام

من هم همین مشکل دارم، وردپرس آپدید شده و پیشخوان وردپرس و پست ها باز نمیشه و این خطا نشون میده


Warning: require_once(/home2/persi116/public_html/pahpadnews.ir/wp-includes/110n.php): failed to open stream: No such file or directory in /home2/persi116/public_html/pahpadnews.ir/wp-includes/load.php on line 1160

Fatal error: require_once(): Failed opening required '/home2/persi116/public_html/pahpadnews.ir/wp-includes/110n.php' (include_path='.:/opt/cpanel/ea-php72/root/usr/share/pear') in /home2/persi116/public_html/pahpadnews.ir/wp-includes/load.php on line 1160

 

در فایلی که اشاره کرده وارد شدم اما متوجه نشدم که چه چیز باید ویرایش کنم

function wp_load_translations_early() {
    global $wp_locale;

    static $loaded = false;
    if ( $loaded ) {
        return;
    }
    $loaded = true;

    if ( function_exists( 'did_action' ) && did_action( 'init' ) ) {
        return;
    }

    // We need $wp_local_package
    require ABSPATH . WPINC . '/version.php';

    // Translation and localization
    require_once ABSPATH . WPINC . '/pomo/mo.php';
    require_once ABSPATH . WPINC . '/110n.php';
    require_once ABSPATH . WPINC . '/class-wp-locale.php';
    require_once ABSPATH . WPINC . '/class-wp-locale-switcher.php';

 

این خط هست که گفته:     require_once ABSPATH . WPINC . '/110n.php';

 

ممنون میشم دوستانی که تجربش داشتن به بنده کمک کنن

به اشتراک گذاری این ارسال


لینک به ارسال

به گفتگو بپیوندید

هم اکنون می توانید مطلب خود را ارسال نمایید و بعداً ثبت نام کنید. اگر حساب کاربری دارید، برای ارسال با حساب کاربری خود اکنون وارد شوید .

مهمان
ارسال پاسخ به این موضوع ...

×   شما در حال چسباندن محتوایی با قالب بندی هستید.   حذف قالب بندی

  تنها استفاده از 75 اموجی مجاز می باشد.

×   لینک شما به صورت اتوماتیک جای گذاری شد.   نمایش به صورت لینک

×   محتوای قبلی شما بازگردانی شد.   پاک کردن محتوای ویرایشگر

×   شما مستقیما نمی توانید تصویر خود را قرار دهید. یا آن را اینجا بارگذاری کنید یا از یک URL قرار دهید.


×
×
  • اضافه کردن...