نوین ادمین

نمایش زمینه های دلخواه برای کاربران ثبت نامی

12 پست در این موضوع قرار دارد

سلام .

میخواستم قسمت زمینه های دلخواه در سایتم فقط برای کاربران ثبت نامی نمایش داده بشه .

یک جا خوندم باید این کد رو استفاده کنم :

<?php  if ( is_user_logged_in() )
{

}
else {
echo "You are not logged in.\n";
}
?>

اما من وقتی از این کد استفاده می کنم کد اصلی به شکل زیر میبشه و php دوم غیر فعال میشه یجورایی و صفحه سایت ارور میده و بالا نمیاد

<?php  if ( is_user_logged_in() )
{
<?php $mid_var = get_post_meta($post->ID, 'dl1',true); if(isset($mid_var) && !empty($mid_var)) : ?>
<img src="http://.../images/download.png" alt="دانلود" width="16" height="16" border="0" align="right" />
  دانلود مستقیم : <?php echo get_post_meta($post->ID, 'dl1',true); ?><br /> <?php endif; ?>
}
else {
echo "You are not logged in.\n";
}
?>

چطوری میشه این کد رو درست کنم ؟

ممنون

ویرایش شده در توسط shahab2005
0

به اشتراک گذاری این پست


لینک به پست

آقای nested عزیز لطف کردن این راهنمایی رو کردن

<?php if ( is_user_logged_in() ) { ?>
<?php $dll = get_post_meta($post->ID, 'dll', true); ?>
دانلود مستقیم : <?php echo $dll; ?>
<?php } else { ?>
<?php } ?>

اما کد کامل نیست . مقداری برای else تعریف نشده . مثلاً این مقدار " برای مشاهده لیتک ها ثبت نام کنید " این کد رو چظوری باید درستش کنم که خطا نده ؟

0

به اشتراک گذاری این پست


لینک به پست

سلام

این رو تست کنید.

<?php  if ( is_user_logged_in() )
{
<?php $mid_var = get_post_meta($post->ID, 'dl1',true); if(isset($mid_var) && !empty($mid_var)) : ?>
<img src="http://.../images/download.png" alt="دانلود" width="16" height="16" border="0" align="right" />
  دانلود مستقیم : <?php echo get_post_meta($post->ID, 'dl1',true); ?><br /> <?php endif;
}
else {
echo "You are not logged in.\n";
}
?>

3

به اشتراک گذاری این پست


لینک به پست
<?php if ( is_user_logged_in() ) { ?>
<?php $dll = get_post_meta($post->ID, 'dll', true); ?>
دانلود مستقیم : <?php echo $dll; ?>
<?php } else {
echo 'تگ لینک';
?>
<?php } ?>

3

به اشتراک گذاری این پست


لینک به پست

<?php if ( is_user_logged_in() ) { ?>
<?php $dll = get_post_meta($post->ID, 'dll', true); ?>
دانلود مستقیم : <?php echo $dll; ?>
<?php } else {
echo 'تگ لینک';
?>
<?php } ?>

من اینو تست کردم عملکردش درست بود فقط لینک های دانلود رو نمیاورد . <?php echo $dll; ?> کار نمیکرد .

0

به اشتراک گذاری این پست


لینک به پست

من اینو تست کردم عملکردش درست بود فقط لینک های دانلود رو نمیاورد . <?php echo $dll; ?> کار نمیکرد .

اون یک مثال بوده. شما باید قسمت لینک دانلود سایت خودتون رو جایگزین می‌کردید


<?php
if ( is_user_logged_in() ) {
$dll = get_post_meta($post->ID, 'dll', true);
echo "دانلود مستقيم : <a href='$dll'>دانلود</a>";
} else {
echo 'تگ لينک';
} ?>

3

به اشتراک گذاری این پست


لینک به پست
<?php if ( is_user_logged_in() ) { ?>
<?php $dll = get_post_meta($post->ID, 'dll', true); ?>
دانلود مستقیم : <a href="<?php echo $dll; ?>">Download</a>
<?php } else {
echo 'امکان بازدید از لینک دانلود تنها برای کاربرانی که <a href="http:www.domain.com/wp-login.php?action=register">ثبت نام </a>کرده اند وجود دارد';
?>
<?php } ?>

3

به اشتراک گذاری این پست


لینک به پست

ممنون . یک نکته که یادم رفت بگم اینه که کد اچ تی ام ال لینک دانلود رو مستقیماً گذاشتم . یعنی dl1 مقدار اینجوری داره :

<a href="http://dl.mohandesyar.com/91/2/Bascom-avr(www.mohandesyar.com).zip" rel="nofollow" >کامپایلر Bascom AVR 2.0.7.3</a>

برای همین نباید از تگ لینک استفاده کنم . کل مقدار رو باید برگردونم . . . .

0

به اشتراک گذاری این پست


لینک به پست

کشس چیزی به ذهنش نرسید در این مورد ؟ بجای

<?php echo $dll; ?>

نمیتونم چیز دیگه ای بزارم ؟

0

به اشتراک گذاری این پست


لینک به پست

دقیقا چه کاری می‌خواهید انجام بدید؟

1

به اشتراک گذاری این پست


لینک به پست

اول اینکه نام زمینه دلخواه در این تابع شرطی dll هست نه dl1

بعد اینکه براحتی با زمینه دلخواه زیر :

<?php if ( is_user_logged_in() ) { ?>
<?php $dll = get_post_meta($post->ID, 'dll', true); ?>
دانلود مستقیم : <?php echo $dll; ?>
<?php } else {
echo 'امکان بازدید از لینک دانلود تنها برای کاربرانی که <a href="http:www.domain.com/wp-login.php?action=register">ثبت نام </a>کرده اند وجود دارد';
?>
<?php } ?>

می تونید مقدار زمینه دلخواه به اینصورت وارد کنید ( تست شده و کار می کنه ):

<a href="http://dl.mohandesyar.com/91/2/Bascom-avr(www.mohandesyar.com).zip" rel="nofollow" >کامپایلر Bascom AVR 2.0.7.3</a>

4

به اشتراک گذاری این پست


لینک به پست

اره فکر کنم مشکلش همین بود .

بجای DL1 از DLL استفاده شده بود که مقدار رو لود نمیکرد . کد درست بود و عمل نمی کرد برای همین خیلی تعجبیدم :D

ممنون

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط stanesti
      با سلام
      من به تازگی یک سایت با وردپرس راه اندازی کردم و الان به مشکل خوردم و هر کار کردم نتونستم حلش کنم و برای همین هم این مطلب رو ارسال می کنم
       
      حالا شرح سوال:
      وب سایت من علاوه بر بخش نوشته ها، از بخش نمونه کار ها، تیم ما، نظرات کاربران و .... نیز برخوردار هست.

      من می خواستم که نوشته هام در پوشه blog/ به نمایش در بیان مثل لینک زیر:
      https://stanesti.ir/blog/how-to-create-gravatar-account/
      برای این منظور اومدم و در داشبورد سایت به "تنظیمات > پیوندهای یکتا" رفتم و این تنظیمات رو اعمال کردم:

      پس از انجام این تنظیمات، نوشته ها به درستی کار می کنن اما نمونه کار ها نیز به پوشه blog/ منتقل شدن مانند لینک زیر:
      https://stanesti.ir/blog/portfolio/argon-dashboard-html-template/
      در حالی که من فقط می خواستم پست هایی که در بخش نوشته ها ارسال می کنم به blog/ منتقل بشن و بقیه پست های بخش های دیگه تغییری نداشته باشن و مثل لینک زیر باشن:
      https://stanesti.ir/portfolio/argon-dashboard-html-template/
       
      حالا به نظرتون چه کار باید بکنم؟ چه راهکاری پیشنهاد میدین؟
       
      ممنون میشم سریع تر جوابم رو بدید چون عجله دارم.
      تشکر
    • توسط jbihamta
      سلام وقتتون بخیر دوستان
      یک مساله خیلی غیر معمول برام پیش اومده اونم اینکه در بخش افزودن پست میخوام ۷ هزارو خورده ای کلمه پیش نویس کنم نمیزاره و بیشتر از  ۵ هزارتا ذخیره نمیشه کسی میدونه از چی هستش؟
    • توسط soshiant
      سلام
      دوستان یه کمک خیلی مهم ازتون میخوام
      به طور پیش فرض تو سایت وقتی کاربر میخواد یه فایل خریداری کنه، به صفحه پرداخت که edd به صورت پیش فرض ساخته میره (همون صفحه ای که رسید و فاکتور و مبلغ کل رو داره و از مشتری ایمیل و مشخصات رو میخواد)
       
      من میخوام تغییری تو این روند بدم. جوری که وقتی کاربر میخواد فایل رو بخره (تصویر 1)
      فاکتور و رسیدی که بعد از زدن روی دکمه پرداخت (تو سایت من اسمش دکمه بفرمایید هست) تو صفحه بعد میده رو میخوام تو همون صفحه و به صورت آژاکس نشون بده (تصویر 2 - با فتوشاپ درست کردم)
       
      ینی منظورم اینه که بعد از زدن رو دکمه، بجای این که صفحه رسید و پرداخت تو یه پنجره جدید باز بشه، میخوام همونجا و به صورت آژاکس فاکتور رو نشون بده و با زدن رو دکمه پرداخت به بانک وصل بشه
      لطفا راهنماییم کنید خیلی مهمه برام


    • توسط sajjad.1156
      با سلام
      دوستان بنده در سایتم از اسلایدر روولوشن استفاده می کنم اما متاسفانه وقتی از 13 لایه بیشتر به هر اسلاید اضافه می کنم خطای ایجکس میده و نمیذاره اسلاید رو ذخیره کنم.
      چه مسئله ای میتونه وجود داشته باشه؟
    • توسط hosseyn
      سلام سایت من به تازگی این مشکل رو پیدا کرده و توی گوگل وب مستر و گوگل سرچ کنسول خطای ایندکس نشدن صفحه اصلی سایت رو میده
      برای تبلیغ گوگل هم از صفحه اصلی ایراد می گرفت ولی با صفحات دیگه مشکلی نداره