رفتن به مطلب
Ali WP

نمایش داده نشدن تصاویر در کروم

پست های پیشنهاد شده

سلام چند وقتی هست که تصاویر در گوگل کروم نمایش داده نمیشن ولی توی سایر مرورگر ها مشکلی نیست
اگه ممکنه راهنمایی کنید
با تشکر

به اشتراک گذاری این ارسال


لینک به ارسال

سلام

کلاً کد قسمت نمایش عکس داخل پست هاتون مشکل داره دوست عزیز ،

اگر هم الان داره توی مرورگر موزیلا شما عکس هارو نشون میده این نشان دهنده این هستش که قبلاً کد عکس ها درست بوده و کش سیو شده بعد که شما کد رو تغییر دادید باز هم داره داخل موزیلا بخاطر کش که سیو شده نمایش داده میشه ، اما داخل مرورگر دیگه ای نمایش داده نمیشه ...

کد فراخوانی عکس ها داخل پست هاتون رو بررسی کنید .

الان بیشتر چک کردم ، داخل مثلاً موزیلا 7.0 debian نشون میده اما ورژن بالاتر نشون نمیده !

در کل همون مشکل من 99% فکر میکنم از کد عکس ها باشه که یه تغییر بدید درست میشه.

ویرایش شده توسط وردپرس فارسی

به اشتراک گذاری این ارسال


لینک به ارسال

ساختار کلی تصایور به شکر زیر هست

<a href=" example.com/images/image1.jpg " rel="attachment wp-att-3251"><img class="alignnone size-medium wp-image-3251" src="example.com/images/image-300x150.jpg" alt="google new logo" width="300" height="150" /></a>

اگه مشکلی میبینید بفرمایید تا اصلاح کنم

درضمن با 3 تا سیستم مختلف هم چک کردم مشکل سایت با کروم هستش 

فکر نمیکنم مشکل جدیدی باشه چون چند جای دیگه هم دیدم که این مشکل رو داشتن

https://wordpress.org/support/topic/image-doesnt-show-up-in-chrome-all-other-browsers-ok

به اشتراک گذاری این ارسال


لینک به ارسال

شما برای تست کردن میتونید با 100 تا سیستم مختلف و مرورگر های مختلف هم چک کنید سایت رو آنلاین ...

فایل index.php ضمیمه کنید .

ویرایش شده توسط وردپرس فارسی

به اشتراک گذاری این ارسال


لینک به ارسال

فایل  index.php:

<?php get_header(); ?>

<section class="content">

	<?php get_template_part('inc/page-title'); ?>
	
	<div class="pad group">
		
		<?php get_template_part('inc/featured'); ?>
		
		<?php if ( have_posts() ) : ?>
		
			<?php if ( ot_get_option('blog-standard') == 'on' ): ?>
				<?php while ( have_posts() ): the_post(); ?>
					<?php get_template_part('content-standard'); ?>
				<?php endwhile; ?>
			<?php else: ?>
			<div class="post-list group">
				<?php $i = 1; echo '<div class="post-row">'; while ( have_posts() ): the_post(); ?>
					<?php get_template_part('content'); ?>
				<?php if($i % 2 == 0) { echo '</div><div class="post-row">'; } $i++; endwhile; echo '</div>'; ?>
			</div><!--/.post-list-->
			<?php endif; ?>
		
			<?php get_template_part('inc/pagination'); ?>
			
		<?php endif; ?>
		
	</div><!--/.pad-->
	
</section><!--/.content-->

<?php get_sidebar(); ?>

<?php get_footer(); ?>

 

به اشتراک گذاری این ارسال


لینک به ارسال

secser چیه که شما در تگ img استفاده کردید حذف کنید مشکل حل میشود

به اشتراک گذاری این ارسال


لینک به ارسال

بیشتر توضیح میدید

توی همه تصاویر به کار رفته چه طوری میشه توی همه ی تصاویر حذفش کرد؟

به اشتراک گذاری این ارسال


لینک به ارسال
در 44 دقیقه قبل، a2h گفته است :

secser چیه که شما در تگ img استفاده کردید حذف کنید مشکل حل میشود

دقیقا کجا هست؟

به اشتراک گذاری این ارسال


لینک به ارسال

content.php و  inc/featured.php 

را قرار دهید لطفا

 

ویرایش شده توسط a2h

به اشتراک گذاری این ارسال


لینک به ارسال

content.php :

<article id="post-<?php the_ID(); ?>" <?php post_class('group'); ?>>	
	<div class="post-inner post-hover">
		
		<div class="post-thumbnail">
			<a href="<?php the_permalink(); ?>" title="<?php the_title(); ?>">
				<?php if ( has_post_thumbnail() ): ?>
					<?php the_post_thumbnail('thumb-medium'); ?>
				<?php elseif ( ot_get_option('placeholder') != 'off' ): ?>
					<img src="<?php echo get_template_directory_uri(); ?>/img/thumb-medium.png" alt="<?php the_title(); ?>" />
				<?php endif; ?>
				<?php if ( has_post_format('video') && !is_sticky() ) echo'<span class="thumb-icon"><i class="fa fa-play"></i></span>'; ?>
				<?php if ( has_post_format('audio') && !is_sticky() ) echo'<span class="thumb-icon"><i class="fa fa-volume-up"></i></span>'; ?>
				<?php if ( is_sticky() ) echo'<span class="thumb-icon"><i class="fa fa-star"></i></span>'; ?>
			</a>
			<?php if ( comments_open() && ( ot_get_option( 'comment-count' ) != 'off' ) ): ?>
				<a class="post-comments" href="<?php comments_link(); ?>"><span><i class="fa fa-comments-o"></i><?php comments_number( '0', '1', '%' ); ?></span></a>
			<?php endif; ?>
		</div><!--/.post-thumbnail-->
		
		<div class="post-meta group">
			<p class="post-category"><?php the_category(' / '); ?></p>
			<p class="post-date"><?php the_time('j M, Y'); ?></p>
		</div><!--/.post-meta-->
		
		<h2 class="post-title">
			<a href="<?php the_permalink(); ?>" rel="bookmark" title="<?php the_title(); ?>"><?php the_title(); ?></a>
		</h2><!--/.post-title-->
		
		<?php if (ot_get_option('excerpt-length') != '0'): ?>
		<div class="entry excerpt">				
			<?php the_excerpt(); ?>
		</div><!--/.entry-->
		<?php endif; ?>
		
	</div><!--/.post-inner-->	
</article><!--/.post-->	

content-featured.php:

<article id="post-<?php the_ID(); ?>" <?php post_class('group'); ?>>	
	<div class="post-inner post-hover">
		
		<div class="post-thumbnail">
			<a href="<?php the_permalink(); ?>" title="<?php the_title(); ?>">
				<?php if ( has_post_thumbnail() ): ?>
					<?php the_post_thumbnail('thumb-large'); // only difference to content.php ?>
				<?php elseif ( ot_get_option('placeholder') != 'off' ): ?>
					<img src="<?php echo get_template_directory_uri(); ?>/img/thumb-medium.png" alt="<?php the_title(); ?>" />
				<?php endif; ?>
				<?php if ( has_post_format('video') && !is_sticky() ) echo'<span class="thumb-icon"><i class="fa fa-play"></i></span>'; ?>
				<?php if ( has_post_format('audio') && !is_sticky() ) echo'<span class="thumb-icon"><i class="fa fa-volume-up"></i></span>'; ?>
				<?php if ( is_sticky() ) echo'<span class="thumb-icon"><i class="fa fa-star"></i></span>'; ?>
			</a>
			<?php if ( comments_open() && ( ot_get_option( 'comment-count' ) != 'off' ) ): ?>
				<a class="post-comments" href="<?php comments_link(); ?>"><span><i class="fa fa-comments-o"></i><?php comments_number( '0', '1', '%' ); ?></span></a>
			<?php endif; ?>
		</div><!--/.post-thumbnail-->
		
		<div class="post-meta group">
			<p class="post-category"><?php the_category(' / '); ?></p>
			<p class="post-date"><?php the_time('j M, Y'); ?></p>
		</div><!--/.post-meta-->
		
		<h2 class="post-title">
			<a href="<?php the_permalink(); ?>" rel="bookmark" title="<?php the_title(); ?>"><?php the_title(); ?></a>
		</h2><!--/.post-title-->
		
		<?php if (ot_get_option('excerpt-length') != '0'): ?>
		<div class="entry excerpt">				
			<?php the_excerpt(); ?>
		</div><!--/.entry-->
		<?php endif; ?>
		
	</div><!--/.post-inner-->	
</article><!--/.post-->	

featured.php:

<?php
// Query featured entries
$featured = new WP_Query(
	array(
		'no_found_rows'				=> false,
		'update_post_meta_cache'	=> false,
		'update_post_term_cache'	=> false,
		'ignore_sticky_posts'		=> 1,
		'posts_per_page'			=> ot_get_option('featured-posts-count'),
		'cat'						=> ot_get_option('featured-category')
	)
);
?>

<?php if ( is_home() && !is_paged() && ( ot_get_option('featured-posts-count') =='1') ): // No slider if 1 post is featured ?>
	
	<div class="featured">
		<?php while ( $featured->have_posts() ): $featured->the_post(); ?>
			<?php get_template_part('content-featured'); ?>
		<?php endwhile; ?>	
	</div><!--/.featured-->
	
<?php elseif ( is_home() && !is_paged() && ( ot_get_option('featured-posts-count') !='0') ): // Show slider if posts are not 1 or 0 ?>
	
	<script type="text/javascript">
		// Check if first slider image is loaded, and load flexslider on document ready
		jQuery(document).ready(function(){
		 var firstImage = jQuery('#flexslider-featured').find('img').filter(':first'),
			checkforloaded = setInterval(function() {
				var image = firstImage.get(0);
				if (image.complete || image.readyState == 'complete' || image.readyState == 4) {
					clearInterval(checkforloaded);
					
					jQuery('#flexslider-featured').flexslider({
						animation: "slide",
						useCSS: false, // Fix iPad flickering issue
						slideshow: true,
						directionNav: true,
						controlNav: true,
						pauseOnHover: true,
						slideshowSpeed: 7000,
						animationSpeed: 400,
						smoothHeight: true,
						touch: false
					});
					
				}
			}, 20);
		});
	</script>
		
	<div class="featured flexslider" id="flexslider-featured">
		<ul class="slides">				
			<?php while ( $featured->have_posts() ): $featured->the_post(); ?>
			<li>	
				<?php get_template_part('content-featured'); ?>
			</li>
			<?php endwhile; ?>			
		</ul>
	</div><!--/.featured-->
	
<?php endif; ?>
<?php wp_reset_postdata(); ?>

 

به اشتراک گذاری این ارسال


لینک به ارسال

دسترسی پوشه uploads و فایلهای توش رو تو روت سایت  چک کنید (پوشه باید 755 و فایلها 666 باشند) 

مشکلتون بخاطر تغییر مسیر آپلوده اگر اینکار رو برای امنیت کردید هیچ تاثیری رو امنیت سایت نداره و فقط باعث بروز مشکلاتی از این قبیل می شه

 

به اشتراک گذاری این ارسال


لینک به ارسال
در 3 ساعت قبل، imanfakhar گفته است :

دسترسی پوشه uploads و فایلهای توش رو تو روت سایت  چک کنید (پوشه باید 755 و فایلها 666 باشند) 

مشکلتون بخاطر تغییر مسیر آپلوده اگر اینکار رو برای امنیت کردید هیچ تاثیری رو امنیت سایت نداره و فقط باعث بروز مشکلاتی از این قبیل می شه

 

درود بر مهارت شما

تصاویر رو به هاست دانلود منتقل کردم اگه ممکنه بیشتر راهنمایی کنید

به اشتراک گذاری این ارسال


لینک به ارسال

مثل این که سطح دسترسی همه ی تصایر 644 هست

چه طوری میشه همشون رو یکجا درست کرد؟(تصاویر توی چندین پوشه ی جداگانه قرار دارند)

به اشتراک گذاری این ارسال


لینک به ارسال
در 34 دقیقه قبل، Ali WP گفته است :

مثل این که سطح دسترسی همه ی تصایر 644 هست

چه طوری میشه همشون رو یکجا درست کرد؟(تصاویر توی چندین پوشه ی جداگانه قرار دارند)

نرم افزار فایل زیلا (filezilla) رو دانلود و نصب کنید و با مشخصات ftp تون از طریق نرم افزار وارد هاستتون بشید پوشه مادر رو سلکت کنید و راست کلیک کنید گزینه file permission ...  رو بزنید و گزینه Recurse into subdirectories رو تیکدار کنید و گزینه apply to file only 

توی کادر نوشتاری بالاش هم بنویسید 666 و تایید کنید

و یکبار دیگه همین کار را انجام بدید و ایندفعه گزینه apply to directories only رو تیکدار کنید و 755 رو وارد کنتید

به اشتراک گذاری این ارسال


لینک به ارسال

خیلی ممنون

فقط دو تا سوال

1-قبلا هم که تصاویر توی هاست اصلی بودن سطح دسترسی 644 بود ولی مشکلی در نمایش نبود چرا؟

2-چرا وقتی آدرس تصویر رو میزنی میاره ولی توی مطالب بازش نمیکنه؟

به اشتراک گذاری این ارسال


لینک به ارسال

روی 666 تنظیم کردم ولی درست نشد

تصاویر توی هاست دانلود هستن توی کروم آدرس به جای dl.domain.com با domain.com شروع میشه ولی توی بقیه مرور گر ها اینطور نیست

اگه ممکنه راهنمایی کنید

به اشتراک گذاری این ارسال


لینک به ارسال
نقل قول

-قبلا هم که تصاویر توی هاست اصلی بودن سطح دسترسی 644 بود ولی مشکلی در نمایش نبود چرا؟

با دسترسی 644 به فراخوانی های داخل سرور پاسخ می ده و با 666 به فراخوانی های همه روی هاست اصلی طبیعیه که 644 نشون بده گرچه دسترسی کامل و درستش نیست 

اینکه نشانی رو نتونه درست بخونه می تونه از htaccess  با شه ولی اینکه فقط تو گوگل کروم این مشکل باشه احتمال قوی مربوط می شه به باگ یه افزونه ای چیزی مثلا افزونه های تشخیص نسخه موبایلی و رسپانسیو کردن با اگنت کاربر کار دارند و نمایشگر رو می خونند یا افزونه های آمارگیر هر کدوم از این دسته افزونه ها از اونجایی که با نوع نمایشگر کار دارند ممکنه باگی داشته باشند که باعث این مشکلات بشه

به اشتراک گذاری این ارسال


لینک به ارسال

برای هاست دانلود از افزونه Hacklog Remote Attachment استفاده میکنم اگه افزونه بهتری میشناسید لطفا معرفی کنید

از چا طریقی میشه باگ رو رفع کرد؟

به اشتراک گذاری این ارسال


لینک به ارسال

روی هاست دانلودتون هم وردپرس نصبه؟ نیازی به نصب وردپرس نبود 

مشکل شما با توجه به اینکه فقط روی گوگل کروم اینجوریه به اسکریپتهای سایت اصلی مربوط می شه نه هاست دانلود

باگ رو که شما نمی تونید رفع کنید ولی هر وقت تونستید باگ رو پیدا کنید می تونید به صفحه افزونه تو سایت وردپرس مراجعه کنید و گزارش باگ رو بدید 

به اشتراک گذاری این ارسال


لینک به ارسال

این مشکل رو فقط من ندارم انگلیسی که جست و جو کردم به نتایج خوبی رسیدم ولی متاسفانه از اصطلاحاتی استفاده کرده بودن که من به فارسی هم متوجه نمیشم

به اشتراک گذاری این ارسال


لینک به ارسال

من نگفتم فقط شما مشکل دارید عرض کردم یکی از افزونه هاتون می تونه باعث مشکل بشه افزونه هاتون رو غیر فعال کنید و تست کنید بعد یکی یکی فعالشون کنید تا افزونه مشکل دار پیدا بشه 

به اشتراک گذاری این ارسال


لینک به ارسال

همه ی افزونه ها رو غیر فعال کردم ولی مشکل بر طرف نشد

این یعنی مشکل از افزونه ها نیست

اگه ممکنه راهنمایی کنید

به اشتراک گذاری این ارسال


لینک به ارسال

به گفتگو بپیوندید

هم اکنون می توانید مطلب خود را ارسال نمایید و بعداً ثبت نام کنید. اگر حساب کاربری دارید، برای ارسال با حساب کاربری خود اکنون وارد شوید .

مهمان
ارسال پاسخ به این موضوع ...

×   شما در حال چسباندن محتوایی با قالب بندی هستید.   حذف قالب بندی

  تنها استفاده از 75 اموجی مجاز می باشد.

×   لینک شما به صورت اتوماتیک جای گذاری شد.   نمایش به صورت لینک

×   محتوای قبلی شما بازگردانی شد.   پاک کردن محتوای ویرایشگر

×   شما مستقیما نمی توانید تصویر خود را قرار دهید. یا آن را اینجا بارگذاری کنید یا از یک URL قرار دهید.


×
×
  • اضافه کردن...