Rohani

مشکل با پیوند های یکتا روی لوکال

2 پست در این موضوع قرار دارد

سلام وقتی پیوند یکتا روی نام نوشته باشه رو لوکال خطای 404 میده

ولی رو هاست درست عمل میکنه.

چه جوری رو لوکال درستش کنم؟

.htaccess هم موجوده با این حال جواب نمیده.

0

به اشتراک گذاری این پست


لینک به پست

مشکل حل شد.

وردپرس‌کاران برای ساخت و پرداخت به افزونه‌ها، پوسته‌ها سیستم وردپرس را به صورت لوکال‌هاست بر روی سیستم خود اجرا می‌کنند. نرم‌افزارهای Xampp و Wamp برای اینکار ساخته شده‌است.

اگر با این نرم‌افزارها کار کرده‌باشید، متوجه می‌شوید که زمانی که از پیوندیکتا استفاده می‌کنید به خطای ۴۰۴‌هاست می‌خورید. و برای کار بر روی بعضی از پروژه‌ها پیوندیکتا الزامی‌می‌باشد. خوب، باید این مشکل رو رفع کنیم، با یک‌آزاداندیش باشید.

برای رفع این مشکل راه سختی در پیش ندارید. به مکانی که برنامه را نصب کرده‌اید بروید پوشه apache و در ادامه conf و فایل httpd.conf را با برنامه Notepad یا ادیتورهای دیگر باز کنید. (از برنامه MS Word استفاده نکنید.)

C:\xampp\apache\conf

در ادامه عبارت زیر را جست‌و‌جو کنید و علامت # را از ابتدای آن حذف کنید.

<code></code><code>#LoadModule rewrite_module modules/mod_rewrite.so</code>

تمام شد. سرور رو ریستارت کنید و از پیوند یکتا لذت ببرید.

در صورتی که سوالی داشتید، همین زیر اقدام کنید.

راهنمای تنظیمات پیوندیکتا در نرم‌افزار Wamp :

کافیه روی آیکون وامپ کلیک کنید و بعد به این مسیر برید.

<code>Apache\Appachi modules</code>

بعد کافیه از لیست ماژول‌های آپاچی به دنبال ماژول rewrite_module بگردید و روی اون کلیک کنید تا فعال بشه. حالا باید وامپ رو ریست کنید، ینی روی آیکون وامپ کلیک کنید و بعد گزینۀ Restart All Services رو کلیک کنید و منتظر بمونید تا آیکون اون سبز رنگ بشه.

ویرایش شده در توسط نایس تـم
1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری