mamadco

نمایش داده نشدن گالری

2 پست در این موضوع قرار دارد

سلام دوستان برای نمایش گالری تصاویر یک پست من از این دستور استفاده میکنم :


<?php if( get_post_type( $post ) == "movies" ) : ?>
<?php
$args = array( 'post_type' => 'attachment', 'numberposts' => -1, 'post_mime_type' => 'image' ,'post_status' => null, 'post_parent' => $post->ID, 'exclude' => get_post_thumbnail_id() );
$attachments = get_posts($args);
if ($attachments) {
?>
<div class="post-gallery inline-list row">
<div class="jcarousel-skin-tango3" id="mycarousel3">
<ul>
<?php
foreach ( $attachments as $attachment ) {
?>
<li>
<a class="group1" href="<?php echo wp_get_attachment_url( $attachment->ID , false ); ?>" title="<?php the_title(); ?>">
<img src="<?php echo wp_get_attachment_url( $attachment->ID , false ); ?>" alt="<?php the_title(); ?>">
</a>
</li>
<?php } ?>
</ul>
</div>

وقتی افزودن گالری رو میزنم و عکس هارو انتخاب میکنم ، این عکس ها در کلاس مربوط به خودشون که اسلایدر هم هست نمایش داده نمیشن و توی خود محتوای پست نمایش داده میشن ، کسی میدونه مشکل از چیه . . . ؟

0

به اشتراک گذاری این پست


لینک به پست

چرا سوالایی که من میکنمو هیچکی بلد نیس ، ای باو

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری