iranianwp

مشکل بعد از بروز رسانی وردپرس blockUI requires jQuery v1.2.3 or later! You are using v1.10.2

39 پست در این موضوع قرار دارد

توی فایل jquery تون سرچ کنید


core_version = "1.10.2",

و تغییر بدید به


core_version = "1.50.2",

2

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

توی فایل jquery تون سرچ کنید


core_version = "1.10.2",

و تغییر بدید به


core_version = "1.50.2",

سرچ کردم همچین فایلی وجود نداشت!

ولی این وجود داشت که تاثیری نداشت f="1.10.2"

اینم لینکش : http://code.jquery.com/jquery-1.10.2.min.js

ویرایش شده در توسط Mekaeil Andisheh
0

به اشتراک گذاری این پست


لینک به پست

اون لینک رو کاری نداشته باشید این فایل رو آپلود کنید به پوشه قالبتون

http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.js

و این کدها را به فایل functions.php


function mytheme_scripts() {

wp_deregister_script( 'jquery' ); // Unregister WordPress jQuery
wp_register_script('jquery', get_template_directory_uri() . '/jquery.js', 'jquery', '1.10.2'); // HTML5 Blank script with version number
wp_enqueue_script('jquery'); // Enqueue it!

}
add_action('init', 'mytheme_scripts'); // Add Custom Scripts

اگر مشکل باقی بود

فایل آپلود شده را باز کنید و تغییری که عرض شد بدید و در کدها هم 1.10.2 را به 1.50.2 تغییر بدید (بعیده که دیگه نیازی داشته باشه)

2

به اشتراک گذاری این پست


لینک به پست

اون لینک رو کاری نداشته باشید این فایل رو آپلود کنید به پوشه قالبتون

http://ajax.googleap....10.2/jquery.js

و این کدها را به فایل functions.php


function mytheme_scripts() {

wp_deregister_script( 'jquery' ); // Unregister WordPress jQuery
wp_register_script('jquery', get_template_directory_uri() . '/jquery.js', 'jquery', '1.10.2'); // HTML5 Blank script with version number
wp_enqueue_script('jquery'); // Enqueue it!

}
add_action('init', 'mytheme_scripts'); // Add Custom Scripts

اگر مشکل باقی بود

فایل آپلود شده را باز کنید و تغییری که عرض شد بدید و در کدها هم 1.10.2 را به 1.50.2 تغییر بدید (بعیده که دیگه نیازی داشته باشه)

واقعا از پیگیری و پاسخهاتون سپاسگزارم .

نمیدونم دلیلش چیه همه مراحل رو دقیق انجام دادم ولی حل نمیشه

من از نسخه 2.3.2 بوت استرپ استفاده کردم و الان نسخه 3.0.2 تازگی منتشر شده

احتمالش هست خطا از فایل js اون باشه ؟

0

به اشتراک گذاری این پست


لینک به پست

اون فایل رو حذف می کنیدمشکل کاملا حل میشه؟

2

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

اون فایل رو حذف می کنیدمشکل کاملا حل میشه؟

فایل jquery رو حذف کردم بازم حل نشد فکر کنم مشکل از فایل js بوت استرپ نسخه 2.3.2 باشه البته شاید

نمیدونم!! :(

ویرایش شده در توسط Mekaeil Andisheh
0

به اشتراک گذاری این پست


لینک به پست

یک وردپرس جدا نصب و تست کنید

حالت پیشفرض

2

به اشتراک گذاری این پست


لینک به پست

نسخه 2.3.3منتشر نشده هنوز آخرین نسخه جی کوئری 1.10.2 است و مشکل به این خاطره که افزونه دستور داره با جی کوئری 1.2.1 به بالا کار کنه و وقتی این دو عدد را در حالت طبیعی مقایسه کنید در واقع 1.10 را باید با 1.2 مقایسه کنید که 1.2 بزرگتر است در نتیجه خطای جی کوئری دریافت می کنید

1

به اشتراک گذاری این پست


لینک به پست

در فایلتون


f="1.10.2"

را هم تغییر بدید

این فایل


http://soheil-system.com/soheilshop/wp-content/themes/Sheilsystem/js/jquery.js

3

به اشتراک گذاری این پست


لینک به پست

در فایلتون


f="1.10.2"

را هم تغییر بدید

این فایل


http://soheil-system.com/soheilshop/wp-content/themes/Sheilsystem/js/jquery.js

این کل فایلهای js من هست ولی طبق راهنمایی شما تغییر دادم ولی بازم این خطا رفع نمیشه

اگر خطا از این فایل ها نیست پس خطا از چیه ؟ افزونه ها ؟

دانلود فایل های js

0

به اشتراک گذاری این پست


لینک به پست

برای حل این مشکل این افزونه را نصب و تست کنید

http://wordpress.org/plugins/jquery-updater/

3

به اشتراک گذاری این پست


لینک به پست

نسخه 2.3.3منتشر نشده هنوز آخرین نسخه جی کوئری 1.10.2 است و مشکل به این خاطره که افزونه دستور داره با جی کوئری 1.2.1 به بالا کار کنه و وقتی این دو عدد را در حالت طبیعی مقایسه کنید در واقع 1.10 را باید با 1.2 مقایسه کنید که 1.2 بزرگتر است در نتیجه خطای جی کوئری دریافت می کنید

بله دقیقا با این توضیح شما مشکل رو پیدا کردم سپاسگزارم

مشکل از یکی از افزونه ها بود

1

به اشتراک گذاری این پست


لینک به پست

سلام یکی بگه این پیغام چیه جدیدا هی میاد :

v8m5gcfiy2k1byc1q7j.jpg

0

به اشتراک گذاری این پست


لینک به پست

وردپرس ۳٫۶، از نسخه ۱٫۱۰٫۲ جی کوئری استفاده کرده که تابع jQuery.BlockUI رو پشتیبانی نمیکنه. حالا تو این بین، برخی از افزونه هایی که این تابع رو دارند، رسما قربانی شدند :) چرا که jQuery.BlockUI در نسخه های ۱٫۲٫۳ به بعد جی کوئری پشتیبانی شده (که ۱٫۱۰٫۲ شاملش نمیشه).

برای حل این مشکل، افزونه زیر رو آزمایش کنید:


http://wordpress.org/plugins/jquery-updater/

2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری