.Ibrahim

عدم نمایش پستهای پیوند یکتا

6 پست در این موضوع قرار دارد

درود به همه

منبنا به دلیلی(مشکل internal server 500) مجبور به پاک کردن فایل .htaccess شدم و سایتم بالا اومد اما پستهام خطای Not Found میاد، تنظیمات پیوند یکتا رو هم از اول تنظیم کردم درست نشد.

لطفاراهنمایی کنید.

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

پیوند یکتا پیشفرض رو هم امتحان کردین؟

ویرایش شده در توسط اشکان
1

به اشتراک گذاری این پست


لینک به پست

بله درست نشد

0

به اشتراک گذاری این پست


لینک به پست

یه بار وردپرس رو راه اندازی مجدد کنید اگه نشد پوسته رو تغییر بدین ببنید مشکل هنوز هست.

2

به اشتراک گذاری این پست


لینک به پست

البته مثل اینکه مشکلتون حل شد.

2

به اشتراک گذاری این پست


لینک به پست

پیوند یکتا را برروی پیشفرض قرار دهید یا هر حالت دیگری ذخیره کنید

2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط smtm
      سلام به همگی!
      بعد از تغییر نوع لینک پیوند یکتا از ساده به نام نوشته یا هر گزینه دیگه حروف فارسی تو قسمت آدرس بار به علامت سوال تبدیل میشه و میره تو پیج 404!

      این حالتی هست که روی نام نوشته قرار دادم به علامت سوال تبدیل میشه و به 404 میرسه:


      و این حالت لینک ساده ست که بدون اخطار 404 هست و صفحه درست نشون میده:

      البته زمانی که به نام نوشته تغییر میدم وقتی که موس رو روی لینک قرار میدم لینک ها همه تغییر کردن یعنی درست نوشته میشه:
      ولی وقتی روی لینک کلیک میکنم و میخواد صفحه رو لود کنه حروف فارسی به علامت سوال تبدیل میشه.
       
      افزونه های Change Permalink Helper، Longer Permalinks، رو هم نصب کردم!
      کد زیر و هم انتهای فانکشن قالب قرار دادم و حتی از لینک   https://yoast.com/research/permalink-helper.php هم برای ایجاد کد ریدایرکت توی فایل htacces هم استفاده کردم ولی باز مشکل پابرجاست.
      دوستای با تجربه اگه چیزی تو این زمینه میدونید لطف میکنید بهم میگید و منو راهنمایی می کنید. ممنون از شما.
      add_filter( 'sanitize_title', 'wpse52690_limit_length', 1, 3 ); function wpse52690_limit_length( $title, $raw_title, $context ) { // filters if( $context != 'save' ) return $title; // vars $desired_length = 20; //number of chars $desired_words = 5; //number of words $prohibited = array( 'the' ,'in' ,'my' ,'etc' //put any more words you do not want to be in the slug in this array ); // do the actual work // filter out unwanted words $_title = explode( ' ', $title ); //if you want more than one switch to preg_split() $_title = array_diff( $_title, $prohibited ); // count letters and recombine $new_title = ''; for( $i=0, $count=count($_title); $i<$count; $i++ ) { //check for number of words if( $i > $desired_words ) break; //check for number of letters if( mb_strlen( $new_title.' '.$_title[$i] ) > $desired_length ) break; if( $i != 0 ) $new_title .= ' '; $new_title .= $_title[$i]; } return $new_title; }  
    • توسط nokte
      بنده سایتم را به سرور جدید منتقل کردم و از طریق درون ریزی خود ورد پرس پست هایم را به سایت جدید انتقال دادم و همه پست ها بدون مشکل منتقل شد ولی متاسفانه تصاویر آن منتقل نشد. برای حل این مشکل تصاویر را که در فولدر public_html/wp-content/uploads روی هاست قبلی بود را به هاست جدید درهمین مسیر منتقل کردم ولی متاسفانه تصاویر مطالبم لود نمی شود. نه تصاویر کچک نه بزرگ. همچنین در قسمت رسانه ها در پنل مدیریت هم تصاویر را مشاهده نمیکنم . انگار ورد پرس هنوز متوجه نشده تصاویری در قسمت رسانه روی هاست در فولدر آپلود وجود دارد.
      حتی من در هاست قبلی هم مجددا از از قسمت ابزار ها > برون ریزی ، رسانه ها به صورت جدا برون ریزی کردم  و در هاست جدید درون ریزی کردم و تیک دانلود و درون‌ریزی فایل‌های پیوست را هم زدم  ولی برای همه فایل ها اررور میداد که انپورت فلان تصویر با مشکل مواجه شد و برای همه تصاویر پشت سر هم این ارور را میداد. اگر تصاویر را از روی هاست فعلی بخواند که وجود دارد پس مشکل از چیست؟ 
       
      لطفا راهنمایی کنید چطور رسانه ها را اینپورت کنم؟ یا بهتره بگویم چطور تصاویر را در هاست جدید نمایش دهم . 
      لزم است بگویم فقط از این روش میخواهم عمل کنم و از روش اینپورت دمو و .. نمیخوام چون وررژش وردپرسم را بالا بردم و ورژن php  را هم از 5.6 به روی 7.2 تنظیم کردم و فقط میخواهم مطالب هاست قبلی روی هاست جدید بیاد نه وردپرس قدیمی.
    • توسط Behzadea12
      سلام 
      چجوری میتونم پیوند یکتا مطالبم رو بر اساس یک متاباکس تنظیم کنم؟
    • توسط alizamany
      سلام و عرض ادب 
      بنده به یک مشکل برخوردم ممنون میشم راهنمایی بفرمایید اول از همه به طور خلاصه توضیح بدم که وب سایت بنده شامل بخش اخبار و فروشگاه هست 
      بخش اخبار در گذشته در دامین اصلی وجود داشت به این ادرس : https://windowsiran.com/
      بخش فروشگاه هم در ساب دامین : shop.windowsiran.com
      وجود داشته بنده بخش اخبار رو به پوشه blog منتقل کردم و ریدایرکت های لازم رو انجام دادم و حدود ۲ ماه از اون ریدایرکت ها گذشت و مطالب داخل گوگل به خوبی ایندکس شد بعد از اون فروشگاه رو انتقال دادم به دامین اصلی و پوشه روت حالا بعد از چند هفته متوجه شدم برخی از تصاویر بخش اخبار نمایش داده نمیشن به عنوان مثال 
       
      https://www.windowsiran.com/wp-content/uploads/2018/01/Command-Prompt.jpg
       
      که می بایست این ادرس به 
       
       https://www.windowsiran.com/blog/wp-content/uploads/2018/01/Command-Prompt.jpg
       
       
      ریدایرکت میشد حالا بنده نمیدونم چیکارباید بکنم ریدایرکت اصلا میشه کرد اگر میشه کجا باید قرار داد و چه کدی باید زد ؟
      ممنون میشم راهنمایی بفرمایید .
    • توسط naderi
      سلام دوستان
      من سایتمو توی گوگل برای سازگاریش با موبایل تست میکنم اما اسکرین شاتی که بهم نشون میده ناقصه و سایت رو کامل نشون نمیده !
      البته کنارش میزنه که موبایل فرندلی هست سایتت
      مشکل رو کسی میدونه از کجاست و به چه شکل میشه حلش کرد؟